Rails2.2で、試しにアプリを起動してみたら、
Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please `gem update --system` and try again.
と、言われたので、
$ sudo gem update --system 
とすると、
Updating RubyGems
Nothing to update
と言われた。
言われたとおりにしたのに。。

解決策

こうしたら
$ sudo gem install rubygems-update
Successfully installed rubygems-update-1.3.1
1 gem installed
出来た。
意気揚々と
$script/server
Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please `gem update --system` and try again.
ええええっ
$gem --version
1.2.0
やっぱり。。
ぐぐってみた。
Rails 2.2.2 と RubyGems 1.3.1 と rubygems-update - Rubyとか Illustratorとか SFとか折紙とか
Rails 2.2.2 と RubyGems 1.3.1 と rubygems-updateComments
と、言う事で、
$sudo update_rubygems
...いろいろやって...
If `gem` was installed by a previous RubyGems installation, you may need
to remove it by hand.

$gem --version
1.3.1
$ script/server -p 4000
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.2.2 application starting on http://0.0.0.0:4000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:4000
** Starting Rails with development environment...
** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready.  TERM => stop.  USR2 => restart.  INT => stop (no restart).
** Rails signals registered.  HUP => reload (without restart).  It might not work well.
** Mongrel 1.1.5 available at 0.0.0.0:4000
** Use CTRL-C to stop.
解決しました。ありがとう!!